Mychaeel, on the Wiki forum: Specifically on that Operators page I firmly believe that it was not a good idea to give each and every operator a heading and a section of its own; menu or not, it's definitely not very readable that way. That's why I started putting the operators in tables (see the "Boolean Operators" section).
Tarquin: I have a suggestion, which may reduce the length & complexity of this page. IMHO it might be more logical, but as I'm not really a coder, more of a hybrid docer / mapper, maybe a moccer... anyway:
Group by operator first, then by variable type. Booleans are the exception, I think the boolean table should stay. But beyond that, how about:
Applies to: String, Boolean, Int, Byte, Float, Vector ... etc
Applies to: Int, Byte, Float, Vector ... etc
Mychaeel: Since there are way more operators than data types that scheme just needlessly bloats the page – and it doesn't reflect how I'd personally start looking for a certain operator either. Use headings instead to group by data type those operators apply to – "Boolean Operators," "String Operators" (
@), "Numeric Operators" (
/), and so on.
Tarquin: I guess that's more what I meant – "numeric operators" for +, - etc, since it's bit bloaty to repeat what + does for byte / int / float.
Wormbo: How about tables like this one:
Mychaeel: Yeah, more or less. I'd keep the first-level grouping by "string," "number" (int, byte, float), "vector," "rotator." I think the columns I used for the boolean operator table work best; rows should be sorted by precedence (highest first):
||all||20||Calculates the sum of both operands|
||Variables||Pre-/Postoperator||Increments the variable by 1|